volumeshadowcopySo, I had this server where I enabled Shadow Copy on the D: volume, and I could create snapshots just fine however the scheduled shadow copy jobs never ran.  If I looked in “Control Panel”, “Scheduled Tasks” I could see that the job had never run, and if I tried to edit the schedule I got an error “0x8007000d: The data is invalid“.  I suspected the scheduler to be the culprit, but after trying whatever I could think of and google I ended up with nada..

In the end, all I had to do was to delete one single file and viola everything works.

What Microsoft claim is that I enabled Shadow Copy before running dcpromo on a memberserver, and that thus the service (Shadow Copy) would try to use an old local account (which is deleted as the server is promoted) to schedule the jobs and subsequently fail.  This in my case however was not true, however as the server was installed in Russia over our wan lines the thing might be that the server had not completed a full replication before I enabled Shadow Copy..

Anyhow, the solution can be found here;
http://support.microsoft.com/default.aspx?scid=kb;en-us;822904

And to break it down, all I needed to do was to delete the one file that was in;

%SystemDrive%\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18

(in my case there was only one, but according to the MS site you should only delete files that begin with “d42”.

0 replies

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.